Jump to content
Sign in to follow this  
weber magic

Central locking not working.

Recommended Posts

The central locking is not working on my car. It has never worked and the guy I bought it from (who'd owned it for quite along time) didn't even realise it had central locking.

Normally no central locking at all (it's not doing a thing) has always lead me to the control unit above the speaker in the drivers foot well on cars I've had in the past but this time it has not proved to be the answer.

I took one off another car that definitely works and it has not cured the issue. I also popped the original unit back into the other car and it worked fine. I had the drivers door card off and the actuator is all plugged in. I have replaced all the fuses in the fuse box and everything else on that fuse works.

Does anyone have any other ideas about what could be stopping it from working?

Sent from my iPhone using Tapatalk

Share this post

Link to post
Share on other sites

Have you tried unplugging the actuators in turn? On my 525e the boot actuator was unplugged when I got it. When I plugged it in it caused all manor of erratic behaviour such as unlocking itself. A replacement solved it leading me to think it had an internal short.

If that cures it I have a load of spares.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this