Sign in to follow this  
Followers 0
Marcdonald

BMW 5 series ongoing issues injectors egr valve and glows plugs

12 posts in this topic

I wonder if anyone has any ideas what could be causing the issues I'm having with my BMW 5 series 57 plate 90k. Started having issues where it would drive fine at 50mph but when pulling away from a junction it would cut out and would have trouble pulling away. Took it to the garage where it had a service with all filters replaced, took it away and same thing happened rang mechanic and he said there were two faults that he had cleared but it must need them fixing, it did, so egr valve and glows plugs got replaced. Drove it away and same thing happened took it straight back and he said he thought it was the injectors so he sent them off to be cleaned, the place that cleaned them said they had never smelt injectors like it. Drove it away again and same thing happened, rang garage and they said put an engine flush through it, did this and same thing is still happening. Have to take it back tomorrow but it's just adding up cost wise. Could it be something as simple as needing another fuel filter on, it got replaced during the service two weeks ago but obviously the issue has been something fuel related I'm thinking, the main things have been replaced but could the fuel filter need replaced again, it could have been contaminated whilst driving it between repairs. If not this any ideas? So far the bill has come to £1300! Thanks for reading, any ideas would he appreciated. Naomi 

Share this post


Link to post
Share on other sites

Cant see where he was going technically just doing a service, clutching at straws a bit?? clearly something is at fault.

Cutting out, to me suggests crank shaft sensor.

Sent from my iPhone using Tapatalk

Marcdonald likes this

Share this post


Link to post
Share on other sites

Hi Kjb1 I've just googled the symptoms of crank shaft issues and you are bang on, it has to be this. any idea of cost including labour? Thankyou 

Share this post


Link to post
Share on other sites

Hopefully cheaper than£1300

Order a genuine sensor from local dealership.

Also you haven't mentioned which engine you have?

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Hi kjb1 

just to let you know you were right it is the crank shaft sensor. The car has been test drove off the garage and didn't diagnose it properly yet you got it just off reading about it! So Thankyou 

kjb1 likes this

Share this post


Link to post
Share on other sites
Hi kjb1 

just to let you know you were right it is the crank shaft sensor. The car has been test drove off the garage and didn't diagnose it properly yet you got it just off reading about it! So Thankyou 

Hi both, glad its resolved for you now. Happy motoring!!! regarding spurious faults, sometimes its better to seek a specialist over a local mechanic who is just your basic oil change non fault finding mechanic. Would have saved you £1300 thats for sure.

Or, pop onto forums first as you have learnt, always someone who can help out or point you in the right direction.

Thanks for popping back to follow up on the outcome, so many times you see it when searching a problem yourself, someone has been in same boat as you regarding an issue, but you never find out the outcome as they never post the outcome to the situation.

How much was sensor and fitting in the end?

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Not sure, he didn't give a price, basically we said it needs done so do it, I'll let you know when we get the bill, I know the part got ordered today. Actually Thankyou as well because when you asked about the engine I didn't know the answer so thought if I logged on to the gov website where you check mot and tax it might come up on there, it didn't, but it did tell me the MOT expired 22.01.17!  Don't know when I would have realised

Share this post


Link to post
Share on other sites
Not sure, he didn't give a price, basically we said it needs done so do it, I'll let you know when we get the bill, I know the part got ordered today. Actually Thankyou as well because when you asked about the engine I didn't know the answer so thought if I logged on to the gov website where you check mot and tax it might come up on there, it didn't, but it did tell me the MOT expired 22.01.17!  Don't know when I would have realised

is it a 535d, 530d, 525d or 520d?

Ahhh from your response I assumed you had test driven it with new part fitted?

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

no never test drove it. Just the garage saying it's the crank shaft sensor, now the part isn't there until tomorrow so fingers crossed we get it back tomorrow. I'll let you know how much it is 

Share this post


Link to post
Share on other sites

hopefully it solves it, let is know

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
no never test drove it. Just the garage saying it's the crank shaft sensor, now the part isn't there until tomorrow so fingers crossed we get it back tomorrow. I'll let you know how much it is 

well??

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0