Jump to content
Sign in to follow this  
E12 fanatic

1980 528i sometimes runs sometimes not

Recommended Posts

I am going crazy trying to figure out what is wrong with my bmw. It will run great for hours and then nothing or it will start and stop immediately. 

Share this post


Link to post
Share on other sites

Hmm, intermittent problems are annoying, I think you need to identify whether it is an electrical issue or fuel problem:

 

I am not sure if the 528i is L jet? or if it has points & condenser, if it is L jet it could be the ignition control unit or coil breaking down, or if points and condenser just replace them anyway as they are cheap.

 

If it is fuel related, I would try the fuel pump relay (on the side of the fuse box) or the fuel pump itself, when it stops, try removing the fuel supply pipe from the back of the fuel rail (Bulkhead end) see if fuel is pumping into a jar (container) when you crank the engine.

 

I don't know what it's like for spare where you are, but if the above fails I would try to plug in a replacement ECU (If it is an L jet car).

 

Please bear in mind that these are things that I would try first.

 

Good luck & welcome to the forum.

 

 

Share this post


Link to post
Share on other sites
On 5/18/2016 at 4:57 PM, E12 fanatic said:

I am going crazy trying to figure out what is wrong with my bmw. It will run great for hours and then nothing or it will start and stop immediately. 

Thanks for your reply. So it doesn't have points pretty sure it's transiterized  ignition also pumpING fuel plenty. I just noticed that the TDC  sensor  has been cut and where the plug was is no longer there I do not know how to wire this back in and can't find any diagrams that show. Thanks again for your help.

Share this post


Link to post
Share on other sites

I had an intermittent problem with a 1979 633CSi with the same L Jetronic. It would start fine from cold but at a certain temp would stop or fail to start. It was a broken coil winding in the distributor and these all have electronic ignition.

Share this post


Link to post
Share on other sites
5 hours ago, Sir Anthony Regents-Park said:

The part number for a new pulse generator (the bit with the copper coil windings) is 12111273287, about $150 from BMW.

Thanks for your reply I tried to get the pulse gejara tor out but I could get it to budge. Also is there a way other then continuity to see if it is working or not.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×