Jump to content

E34 Suddenly Not Starting - No Sound from Fuel Pump!

Recommended Posts

Ok, so bear with me as I'm pretty new at diagnosing/fixing my own cars myself, and mostly all the mechanic work I've done has been based on help from the internet. I'm going to explain the situation as clearly as possible, so to narrow down what the problem may be.

The Car - 1991 BMW E34 525i, M50 Non-Vanos engine (RHD, manual gearbox, almost 70000 miles). I've owned it for a few months now, and its done very little mileage the last few years, so I expected things to go wrong early as I am using it daily. Soon after purchase I have replaced the Thermostat, Radiator, Water Pump and cleaned out the Heater Valve.

The Problem - Ok, so I drove to work just fine, with no notable issues or irregularities that I was aware of. I parked on a reasonable slope with the nose upwards (sorry for the detail, but I just want to make sure I cover everything), which I've done before occasionally with no issues, though typically I park the other way.

Late that afternoon, I try to start the car to leave work. It turns over, but no signs of life. First thought was it had dropped all its fuel, as it clearly wasn't getting any, or not getting a spark (I checked, still had about a third of a tank). It was pretty cold, around 0 Degrees Celsius, but its started in colder before.

Came back on Sunday to drop off the car a co-worker had lent me, and out of curiosity to tried to start the BMW. What do you know, it starts. A little hesitant, but after a few seconds it sounded fine. However, after attempting to drive it home, it cut out when overtaking at 70mph about 2-3 Miles down the road frown.gif

My fixing attempts so far - Ok, so after getting the car towed home, I began investigating. 

First thought was fuel pump, I wasn't hearing it start up when turning the ignition, and the same when turning over.
Checked plugs, all look fine and dry with no sign of fuel in the cylinders so definitely not flooded. Not much smell of petrol either, son again pointing towards the fuel pump not pumping.
Checked and confirmed spark on 2 plugs, just assumed the others are fine too.

So after making my mind up that it was the fuel pump, I confidently replaced it. But, after turning the key I hear no signs of life. Still won't start.

Here's where I could do with some help - I'm guessing its some sort of electrical issue, which I really was dreading. I'm terrible with electrical stuff, I don't know my Amps from Volts, and would't have a clue what to do with a Multimeter :???: 

From browsing Google, it seems possible my Crankshaft Sensor is gone. I notice there is a dent on the side of it, but I know that has been there for a while. Anyone know what could cause it to fail? We have had terrible rain/floods for the past 2 weeks, not sure if that may shorten its life?
Also, would the CPS stop the pump working, as I'm convinced its not doing anything?

Seems like it could also be a relay, and TBH, I don't even know what one is! Is it just like a bigger fuse?
Anyway, Fuse 23 looks fine, and have tried swapping it.
In the E-box, I have a strip of 3 Relays, Orange Blue then White if I recall correctly. Most say the middle one (blue in my case, 4 Prong) is the Fuel Pump Relay, and Jumping pins 30-87 with turn it on. I've tried that with no success. Knowing nothing about relays, are the like fuses and have different ratings, or are all the same barring number of prongs? And where can you buy the correct ones in the UK (online or in store)?

To Conclude - Any suggestions or help will be greatly appreciated, and let me know if photos would make things clearer (I can take some of the E-box for example when I get home from work).

Share this post

Link to post
Share on other sites

Just answered this on another forum :-) Edit your profile to show your location. Somebody might nip round with a meter and check out your fuel pump relay for you. As you have spark, your CPS may well be OK. But you need a meter to check that too

Share this post

Link to post
Share on other sites

If you can get someone else to turn the key, put your hand on the relays and you should hear and feel the click.


Here's a guide to relays-




terminal 30 is battery power, so that should always be live.


85 and 86 are the triggers, sometimes they'll activate the relay by putting 12v to one of those, but you can also have ones were there's always 12v to it, and the ground conection is switched to activate it.

That is what will make the click.


When it clicks, it'll connect T30 to T87, that was the connection you were bridging.


The pin87 should run direct to the fuel pump, so check to see if the relay clicks, if you have 12v at T30, and also if you jump 30>87, you should have 12v appearing at the fuel pump.

Share this post

Link to post
Share on other sites

Really struggling with this, no luck with a replacement Crankshaft Sensor. Still no sign of the Fuel Pump running, no matter if I'm jumping the FP Relay or not.

When turning the key I hear quite a lot of clicks, and a constant buzzing from somewhere under the intake manifold, anyone know what that might be?

Also got my hands on a Multimeter; I'm getting battery voltage across the FP Relay pins 30-87, and on the DME Relay with car turned off, battery voltage across pins 30-85 (not 86, can be either according to the Bentley manual). Apparently I'm supposed to get voltage from pins 87 -87A on the DME Relay, but get almost none.
And fuse 23 gets no voltage no matter what I do, jumping FP Relay or not, key on or off.

Currently looking for someone in the area who is capable of diagnosing exactly what the issue is, as I'm stumped.

Share this post

Link to post
Share on other sites

One thing you can do is unplug the fuel pump plug, stick the multimeter into the terminals, and then get someone to switch the engine on and crank it.
If you see 12v there, you have a dead fuel pump.

Share this post

Link to post
Share on other sites

Ok, issue resolved! Many thanks to the help given, I never would have done this on my own.


Anyway, the issue seemed to be with some aftermarket wiring (still not sure what its purpose was, I'll investigate later) which I ended up cutting off, then connected the original green/mauve together. Now runs perfectly, with the Fuel Pump coming in properly rather than just jumping it to run all the time.



Just changed the oil, fuel and air filters, changed oil and plugs, its ready for the road again. Thanks for the help, I'll no doubt be back in future whenever the next thing goes wrong! :D


Proof that the car drives - and quick test of the new winter tyres ;)

Share this post

Link to post
Share on other sites

Hi, I have similar issue, could you say more about the wiring problem/solution, I'm starting to think my issue is with ews, runs like crap to suspecting vac leak, ICV or head gasket, but fuel pump is not priming and seems to only kick in once car is running. Problem came with engine install.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now