Twiglet

What did you do to your E60/61 today?

4,396 posts in this topic

Ha! Yes it warns you on the container that it's pretty nasty smelling, and they are not wrong! Skin irritant too, and very bad for eyes. It's a bit of a thin gel and didn't spray too well in the sprayer I had. Does the biz though.

Sent from my Vodafone Smart ultra 6 using Tapatalk

Share this post


Link to post
Share on other sites

MOT was due on 25/2 but got it done early - passed, no advisories.

Brake fluid done at local indy. Planned to DIY but no time, and £45 including vat seemed like a good idea. Dealer price £128.

Sent from my Vodafone Smart ultra 6 using Tapatalk

Share this post


Link to post
Share on other sites
On 24/02/2017 at 8:02 AM, Vlady said:

Ordered 2off Kumho KU39 XL, now I am not sure if there is a difference between the one I ordered and the Kumho KU39 Ecsta Le sport, does anyone know?

 

Cheers

Have you used kumho before? I need to replace my 2 fronts as 1 has a slight bulge in but don't wanna pay top tyre price so I'm looking at something midrange

Share this post


Link to post
Share on other sites
35 minutes ago, e60530i said:

Have you used kumho before? I need to replace my 2 fronts as 1 has a slight bulge in but don't wanna pay top tyre price so I'm looking at something midrange

There are very good reviews here about Kumho, but me personally no, never used it before, decided to give it a go as people do really recommend it.

vinchenzo and e60530i like this

Share this post


Link to post
Share on other sites

I put KU39s on my 3.2 Vectra (before I got the E61) and was very happy with the performance both wet and dry.

The one problem I did have was vibration above 60mph just after fitting. Turns out they have to be seriously spot on with balance - even a tiny bit out makes a noticeable difference.

Share this post


Link to post
Share on other sites

This I went to Eden tyres in Derby and I had already spoken with them to order me in 2 kumhos. ( the difference in me getting them and taking them and them ordering them was £2 extra  wheel)

 

Full alignment on the Hunter machine they have  the bill was £257.

 

This was for the fronts only though.

 

Will report back after ive done a few hundred miles at the weekend, but I ordered them on the backing of the reviews on here as im new to BMW ownership.

Vlady and e60530i like this

Share this post


Link to post
Share on other sites

Well not so much 'on' the E61 but think I've figured out why I get the problems on a cold start - rough running, 1/2 power, Inj 1 shutoff ...  I'm pretty certain it's down to loss of pressure in the fuel rail over time. Question is, do I have a leaking injector or is the fuel line draining back? I can't find a non-return valve on RealOEM so unless one is built into the HPFP and has a tendency to fail, I'm thinking about fitting one into the fuel supply line. Want to check pressures and a few other things too so just ordered the cable from CableShack.

 

Now we wait....

Share this post


Link to post
Share on other sites

Put a tiny crack in my front bumper running into the biggest hare I have ever seen on a flowing B road. 

 

Might go back get it for tea. 

Edited by Wabby
Mashed Potatoes, e60530i and Westy like this

Share this post


Link to post
Share on other sites
8 hours ago, Grizzle_E60 said:

Replaced rear plate screws, and fitted new front grills. 

IMG_20170301_150029.jpg

They're the newer f10 style grills? 

Share this post


Link to post
Share on other sites
1 hour ago, e60530i said:

They're the newer f10 style grills? 

Yes they are mate. 

e60530i likes this

Share this post


Link to post
Share on other sites
Have you used kumho before? I need to replace my 2 fronts as 1 has a slight bulge in but don't wanna pay top tyre price so I'm looking at something midrange

It's the only tyre I will use brilliant tyre had them on all my cars

Sent from my HUAWEI VNS-L31 using Tapatalk

David Lansley likes this

Share this post


Link to post
Share on other sites
I put KU39s on my 3.2 Vectra (before I got the E61) and was very happy with the performance both wet and dry.

The one problem I did have was vibration above 60mph just after fitting. Turns out they have to be seriously spot on with balance - even a tiny bit out makes a noticeable difference.

The only fault I can report is more road noise with these tyres but still awesome

Sent from my HUAWEI VNS-L31 using Tapatalk

Share this post


Link to post
Share on other sites

Well the cable and software from Cable-Shack.co.uk arrived yesterday (that Jimmy don't hang about!).... installed on a W10 lappy last night and my investigations into the crappy cold starts/inj1 off/half power continued today.

Just having a 'play' with INPA flagged up a noticeable difference in the lambda 1 front readings compared to the other 3 so I may have found (I hope) a possible/probable culprit.

In the course of things, the final thing I did was reset the adaptations to hopefully allow the E61 to re-learn values based on current data, rather than try to deal now, with values learned whilst in the hands of previous owners. Can't hurt.

Test runs having deleted adaptations.... like having a new engine!

 

The story continues....

Share this post


Link to post
Share on other sites

Pictures not great but fitted some spiders to the new car today, they were a bargain, I don't think the guy selling them really knew what he had. Very happy with them as they it was the only thing missing off the car that I wanted when I bought it. 

 

Not done many miles yet but these are non run flats and they seem to handle the bumps much better than the run flats so that's a bonus. 

20170306_191439.jpg

Westy likes this

Share this post


Link to post
Share on other sites
3 minutes ago, Chu said:

Are they 18 reps? They look small

Nah genuine 19s I made sure of it must just be the angle of the photo, not staggered though as they're off an e61 so could do with spacers on the back when I get around to it

Share this post


Link to post
Share on other sites

Washed the 5 today. Had a good 1000 miles worth of road muck on it and was in need of a long clean. Front of the car is peppered with stone chips so I need to order up a touch up pen.

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
Washed the 5 today. Had a good 1000 miles worth of road muck on it and was in need of a long clean. Front of the car is peppered with stone chips so I need to order up a touch up pen.

Sent from my iPhone using Tapatalk

Well that was a waste of time! Driven 50 miles this morning and the car looks like it's not been washed :(

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Ditto. Washed mine then had to travel a stretch of wet road that was full of lorries travelling to and from a construction site. Transformation from smart to sh*te in 5 minutes.

Sent from my Vodafone Smart ultra 6 using Tapatalk

Westy likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now