Jump to content
urquattro

Alpina V8 4.6

Recommended Posts

knew the gleaming black monster had a few problems and not particularly fazed (yet)

 

auto box oil/filter changed and re set to factory, oil and filter done, brake fluid changed but I am still

not happy re coolant system efficiency, suspect water pump or radiator full of crap as poor circulation but car not being used.

did renew thermostat and housing from oem bits as first pass, not much better on static test.

 

so, this week:

renew viscous, renew water pump, check all hoses and have exhaust sniffed re head gaskets ok.

will also have radiator/system flushed out and cleaned so nothing left to chance.

coolant tank etc fine, no fluid losses etc and car runs perfectly with seized up viscous = full time coolant fan.

other minor jobs done as well but not happy the indie didn't spot the coolant issue when allegedly full service was done, he not getting this weeks work and that will be done where i can see the car/workshop.

 

lovely car, will just press on with above, get cabin heater working and air regassed but renewed already is climate control panel, water valve and auxilary w/pump as working way round "where is the issue".

Therefore i guess the full coolant circulation is not happening and fluid not being pushed/sucked into heater matrix, all fans, flaps, aux. pump fine as tested this week end.

Share this post


Link to post
Share on other sites

Does the V8 have the secondary electric water pump at the base of the fan cowl ?

 

I recently did a 530i that had no cabin heat,the plug had fell off the secondary pump (or hadnt been connected at previous repair)..  Immedietly the heater was hot ad has been great ever since.

Share this post


Link to post
Share on other sites

thanks to all, there is no cabin heat despite new valve chest/small pump block, new thermostat/housing etc, garage admitted did not road test.

so back there today, pleased to know there maybe a second pump at base of fan cowl so that a possibility.

 

so will look for second fan re above and taking water pump out as a precaution, viscous was stuck and fan fully engaged all the time.

 

plenty of patience and it really does motor down the road plus road holding so diff, to the faithfull 540 T.

 

will post update this week when I am back from the menders as well.

regards,

keith

Share this post


Link to post
Share on other sites

small update:

apparently getting the water pump off was a bit tricky re the last bolt

old water pump was worn but functional - it was replaced with o.e.m.

so we now have the new bit above plus stat and t/stat housing plus new viscous fan coupling so it will free wheel correctly.

 

we have engine cooling ok but no cabin heat.............think we just have the case of air lock

 

so we now jack up o/side wheel and start the bleed process.

no engine problems as old w/pump was working ok but old.

 

so upwards and onwards.

Share this post


Link to post
Share on other sites

hedgehog ok, full fan speeds and good climate control including it now possible to hear to compressor reacting to air con function,

bit annoying but never mind its relatively minor aggro after E34 M5 farces. !!oo

 

finally found the p.o. bodge.

the heater matrix is bypassed so a severe leak at a guess.

 

so main cooling system now fixed.

 

need to strip out old heater matrix and then be clear if it just matrix issue,  start next week as it buried (i think) in the console.

 

not really happy on this one but will get there.

Edited by urquattro

Share this post


Link to post
Share on other sites

Rob, i shared your thought on this as there was nowhere else to go........ :oops:

 

will get it stripped out re "what" next week and get it done with some help.

 

its such a good car and for the price i expected minor issues. !! but I have good experience of issues and solving with my pile of good and bad wheels.

 

will post and update, only air con and dvd player left to sort out, not bothering with tv though.

 

by the left, its rapid......

Share this post


Link to post
Share on other sites

Sorry to hear about the heater bypass Keith - I bought an E24 with a similar arrangement and suspected the matrix was leaking but was delighted to find the previous owner had only done it to reduce the cabin heat from a failed heater thermostat valve.

Good luck.

Share this post


Link to post
Share on other sites

What's up with the DVD player Keith?  Do you mean the sat nav?

 

No, Sat nav (original/old but works fine) - its got twin dvd players in the rear of front headrests, so the play station needs fiddling with by the sparky just in car g/children ever need a ride, also I like it all to work........

it is just not providing a video/picture he says, i have no need from front seat.

 

I would be lucky if it just too hot and therefore bypassed,,,,,,,,,,,I recon it is leaky matrix or front or rear pipes or perhaps the whole lot.

Share this post


Link to post
Share on other sites

Heater matrix had collapsed hence bypass.

 

All out now................

 

sourcing good replacement, whole lot including heater box, both heater and air con matirx etc and will do the repair properly with new seals kits. :evil:

Share this post


Link to post
Share on other sites

Inside stripped, carpet and underlay were soaked by anitfreeze leak, heater matrix badly corroded !!

transplant now (hopefully) organised - bits arrive at weekend via Will mobile.

 

live in hope of resurrection  of the black shadow, full of confidence as usual,

Share this post


Link to post
Share on other sites

Courtesy of Will's pile of bits enroute, Cotswold as well, plus helpful techie we will win - one way or another.

 

gone down a peg in power/horse power thought - just taxed the RS2 for 6 months, its so good to drive etc but wont use it when salt around.

its like a dainty M5T but rdh and full quattro drive train.

 

i am fortunate that i have the time and funds to get the Alpina sorted out, its only 540 bits we are needing so remain confident.

 

it is a nice car, expected some issues re the price paid anyway but new the alpina bits were fine.

 

update Sunday,

many thanks to Will, his round robin trip delivered the key bits last night, hope my comments above re on 540 climate control work out.

techie starts the rebuild early next week after i deliver the bits.

 

fingers crossed re compatibility of climate control system, should be ok but that my only concern.

Edited by urquattro

Share this post


Link to post
Share on other sites

carpets cleaned and dry ready (problem was foam underside) for next monday as front carpet fitted first and immediately followed by back.

 

shell floor dried, cleaned and protected, replacement air bag module ready for fitting first thing on monday.

 

complete heater box assembly from Will looks it will fit and do the business, so work and patience needed.

 

new drier here for aircon when regas done as well.

 

cautious coolant refill and bleed and test temperatures re +/- re climate control pane.

 

maybe the end is just over the horizon?

Share this post


Link to post
Share on other sites

saga goes on: :oops:

 

interior dried out and cleaned, carpets dried and cleaned and fitted.

heater box fitted, new hoses where needed or missing, now coolant added.

overnight left (unstarted) as possible leaks being investigated.

 

next connections of wiring and sensors incl. climate control panel etc.

 

remain optimistic, such a good car i still think. :idea:

Share this post


Link to post
Share on other sites

this is what happens when you have too much spare time, ambitions and surplus funds - you buy a problem then get immersed. !!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×