Jump to content

Mad4it

Members
  • Content count

    5
  • Joined

  • Last visited

  • Feedback

    N/A

Everything posted by Mad4it

  1. Expansion tank empty twice in 4 days.

    As promised, update on the coolant vent pipe leak and attempted temporary fix. Put an additional pipe clamp on the very end of the rubber hose pictured in previous posting. Might have gotten away with it if I hadn't attempted to fit the small diameter pipe back in the cowling clips. Tride to replace the plastic pipe with copper brake pipe but pipe needs to be about 7mm OD. 2nd option was 2 x 8mm plastic in-line connectors and a 7.6mm bore fuel injection rubber tubing and fuel line clamps (14mm). The in-line connectors came with 12mm clamps. just big enough to go over the OE hoses but too small for the new repair pipe. So far it is proving to be watertight. Enquiry placed with Cotswold BMW last night to order a BM OE replacement.
  2. Expansion tank empty twice in 4 days.

    I have a similar issue but I noticed dried coolant spray on the top hose. Upon inspection radiator cowling wet from the top down (RHS when viewed from the front). Today I removed the bonnet catch panel and the top radiator cover. The leak is from the join in the vent pipe. I will either try recrimping the original clamp or replace with a fuel line clamp as a temporary fix until I get a new vent pipe assy from main stealer. Will update tomorrow on the "fix"
  3. E60 wiper arm

    I bought one from Cotswold BMW (you might have heard of them) With discount through the forum, 67 quid delivered. Took me about 30 minutes to fit. Not worth getting used as it is a weak area and prone to fail.
  4. Car Salesmen Celebrating.

    Either because I have a child like sense of humour or it's due to my age, but the 'shit joke' as it's been called made me chuckle for nearly a minute. Got any more?
  5. Hi, I have a 2008 E60 525i. I haven't posted before but had the same issue a couple of years ago. What got me puzzled was the fact the water seemed pure and not dirty in any way. Lift the bonnet, near side towards the bulkhead is a black lid with about 10-12 bolt heads holding it on. You will have to remove the trim from around the wipers and possibly the filters too, first. Unscrew all the bolts and remove the black lid. The box is full of wires and connections.......and water! There is a drain grommet at the very bottom. Clear the grommet and the water will run away. About half way up the box is a large hole where the cables go through the bulkhead and into the cabin passenger side footwell. (behind the glovebox). When the water builds up to the level of the hole, the water enters the cabin too. Replace lid, filter, trim etc. and you should cure the problem. Not opened mine since. Maybe I should after 2 years but not had ANY signs of a damp footwell since.
×