Casper Smith

Members
  • Content count

    109
  • Joined

  • Last visited

  • Feedback

    0%

About Casper Smith

  • Rank
    Member
  • Birthday

Garage

  • Garage
    E60 535D

Recent Profile Visitors

740 profile views
  1. Thanks Phil, Payment done via PayPal.
  2. Hi Phil, Do you just sell the seals? Items 2 & 3?
  3. I've just spoken to Forge as mine is also leaking, the one for the 3 series will not fit but they are developing one to fit the 5 series & should be out in 4 - 6 weeks. I've spoken to Phil at Cotswold & a direct replacement from him is a little pricey so just going to wait for the Forge one as it should be better. Currently trying to resolve an over boosting issue & hoping this could help.
  4. Thanks Phil, appreciate your help.
  5. Good Afternoon, My red hose is letting by between turbo & intercooler, common fault it appears. Can you quote for a replacement pipe & related seals that are required. I believe the parts were upgraded in 2009? Is that correct & would they be: 11617812274 & 11618506786? REG: NM07 UUJ Thanks Dan
  6. Passed MOT yesterday 😃 0.22 on the smoke test, happy with that as it's the 1st MOT without the DPF. Sent from my SM-G925F using Tapatalk
  7. Snaps of my brother & my car together today. He's got a pre LCI 545i. Bit of a dog when he got it but slowly getting it up to scratch. It's got Xenon's, comfort seats & Logic 7. Last two I wish I had on mine! Sent from my SM-G925F using Tapatalk
  8. Had the alignment done yesterday. Managed to squeeze in a quick clean today. Sent from my SM-G925F using Tapatalk
  9. Just found that Vossen have a 3d wheel configurator & have a 3d model of the E60 M5. Handy if you're thinking of changing wheels or just wanting an idea. http://vossen3d.com/?scene_BMW_M5_E60 Putting it out there. Thanks Dan
  10. New fuel filter, track rod end & hand brake adjusted. Getting ready for MOT next month. Sent from my SM-G925F using Tapatalk
  11. Have to agree. Sent from my SM-G925F using Tapatalk
  12. Thanks for the input chaps. ☺ Sent from my SM-T280 using Tapatalk
  13. Brake pedal! Just wondered if anyone has or has had this issue. I'd say 9 times out 10 the pedal is solid when starting the car. I've checked the scuttle drains, no issue. I've been searching for any info but cannot find anything concrete saying that it could be this or that. It has no bearing on the performance of the brakes as when the engine starts its totally fine. I assume it's a vacuum leak. Thanks Dan Sent from my SM-G925F using Tapatalk
  14. Yes, my mate loves taking mick stating at least they're the right way round on his Audi. Pah....... Sent from my SM-T280 using Tapatalk
  15. Avon Tuning did mine. Bit of a drive for me but read good things & they done it all in one hit. Touch wood had it done since last July & no issues so far. Only thing with them I didn't realise is that it didn't include a rolling road as they've written & developed the map for the 35d engines, he did take it out for a spin to make sure it was hitting the right notes. So quite keen to get it on a RR so see what it's actually making. Sent from my SM-G925F using Tapatalk