Jump to content

Olsrey

Members
  • Content count

    66
  • Joined

  • Last visited

  • Feedback

    0%

About Olsrey

  • Rank
    Newbie

Profile Information

  • Gender
    Not Telling

Garage

  • Garage
    2002 530i
  1. Olsrey

    '05 525d No Power

    One or both or my thermostats aren’t working either so need to replace them. Have bought them but with my limited time free it might take me weeks to fit them.
  2. Olsrey

    '05 525d No Power

    Cars fixed now, thanks all for the help. Turned out the turbo actuator couldn’t move because the rod was seized to it. Turbo vane arm moved freely though.
  3. Olsrey

    '05 525d No Power

    How do I check the last three of that list for being faulty or good?
  4. Olsrey

    '05 525d No Power

    Thanks for that. I’ll have the day free tomorrow, what would you suggest I check? I do want to at least try taking the actuator off and making sure it moves freely and check the wiring to it if I can locate where it goes.
  5. Olsrey

    '05 525d No Power

    Right OK. Don’t suppose you can list the conditions that need to be met so I can monitor them whilst I do a drive tomorrow to try get it to regen please?
  6. Olsrey

    '05 525d No Power

    Might be a silly question, but I know for a normal regen to happen certain conditions need to be met first; engine coolant temp for one, but does forcing a regen get around these conditions or will forcing a regen not work if a normal regen won't work?
  7. Olsrey

    '05 525d No Power

    C310 showed 0 back pressure. Not sure if that’s a fault of it or not so will try with Carly on my way home tomorrow.
  8. Olsrey

    '05 525d No Power

    Yeah I have done before for my old car so I’ll give it a go. Do you think it would be worth getting a company to come out and do a carbon clean to help clear the dpf too?
  9. Olsrey

    '05 525d No Power

    Can Carly force the regen in the same way? If so I’ll be able to do it sooner with that.
  10. Olsrey

    '05 525d No Power

    I have been told to check vac lines but I’m not home now till tomorrow evening at the earliest so will have to do it then. would any of you expect the turbo actuator to move when being revved? The actuator has started to make odd noises when I unlock the car
  11. Olsrey

    '05 525d No Power

  12. Olsrey

    '05 525d No Power

    Only data I get from DDE under the particulate filter menu is these
  13. Olsrey

    '05 525d No Power

    Haven’t already but I will next time I use it, was told by someone else to check the actuator moves when being revved and it doesn’t move. From memory of my old 318d i could hear the actuator moving when I unlocked the car, but today when opening the 525d I could hear a noise but not what I was used to from the old car. Fault codes picture will be attached too.
  14. Olsrey

    '05 525d No Power

    Ah OK. Will try that when I get chance. If it was limp mode would the boost readings get that high though? According to google 1453hpa is roughly 21 psi
  15. Olsrey

    '05 525d No Power

    I’ll see if I can get inpa installed on the laptop again. Didn’t know the manual gearboxes had an ecu though?
×